beta
Returns & Delivery - Incident - Initial Notification
Incident Report for PB Products
Resolved
The Monroe, NJ Hub is back in operation although under generator power. For further updates, please refer to the Weather Alert post on our Pitney Bowes “Dispatch” website here: https://thedispatch.pitneybowes.com/uncategorized/weather-alert/
Posted Aug 07, 2020 - 16:26 EDT
Monitoring
Due to Hurricane Isaias, our Monroe, NJ hub lost over a day of processing from road closures, power outages and downed power lines. As such, delivery and return parcels flowing through the Northeast region may experience a minor delay in processing time. Currently, the hub is operating through a generator, and we are working closely with the utility companies for full restoration.
Posted Aug 07, 2020 - 13:15 EDT
Identified
Due to Hurricane Isaias, our Monroe, NJ hub lost over a day of processing due to road closures, power outages and downed powerlines. As such, deliver and return parcels flowing through the Northeast region may experience a minor delay in processing time. Due to hazardous conditions, the building is open to receive freight only and interfacility freight is being diverted. Currently, the power to the hub is still out and we are working closely with the utility companies for full restoration. Due to the wide-spread impact of the storm, we do not have an ETA for full-service restoration.
Posted Aug 05, 2020 - 14:42 EDT
This incident affected: Delivery API & Technology (Delivery Integration (API & Files)) and Returns API & Technology (Returns Integration (API & Files)).