beta
Expedited Delivery Services - Incident - Initial Notification
Incident Report for PB Products
Resolved
This incident has been resolved.
Posted Dec 17, 2022 - 13:53 EST
Identified
There might be delay from our end as tracking system is affected due to increased response time from USPS.

ref:_00D309tI._5005x1mYGlt:ref
Posted Dec 17, 2022 - 13:39 EST
This incident affected: Ecommerce APIs (Formerly Shipping API) (Tracking).