beta
Expedited Return Services - Incident - Initial Notification
Incident Report for PB Products
Resolved
We experienced a technical issue earlier today. The reprocessing of Tracking files is almost complete and we can now see the "Delivered" events being populated.
We shall continue to closely monitor the situation.
Thank you for your continued partnership with Pitney Bowes.
Posted Jan 19, 2024 - 12:31 EST
Investigating
We are currently experiencing technical issues with our PB Expedited Return Services in the PRODUCTION environment. We noticed problems in processing Tracking files which is causing delays in sending the "Delivered" events for last few days. We anticipate the backlog to clear by 6:00 PM ET.
Please note, this issue is specific to Tracking and does not impact label creation in the Production environment.

Our Emergency Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of the APIs. We will send you an update as quickly as possible.
Posted Jan 19, 2024 - 05:17 EST
This incident affected: Returns API & Technology (Tracking, Returns Integration (API & Files)).