beta
USPS Tracking Services Issue
Incident Report for PB Products
Resolved
This incident has been resolved at 6.30 PM ET.
Posted Jan 22, 2024 - 18:40 EST
Investigating
USPS is currently experiencing technical issues with their Tracking Services. The issue began at approximately 09:30 AM ET today. There is a delay in the USPS providing scans events as well as displaying scans on their website. The USPS website is displaying scans events however the data may be stale.

Once we have more updates from USPS, we will send you an update as quickly as possible. If you have any questions or concerns, please feel free to contact us.

Thank you,
Client Support Tech Services
Posted Jan 22, 2024 - 12:51 EST
This incident affected: Consumer Connect (Tracking), Returns API & Technology (Tracking), Delivery API & Technology (Tracking), and Ecommerce APIs (Formerly Shipping API) (Tracking).