beta
Borderfree Order Related Emails Processing Delays
Incident Report for PB Products
Resolved
Dear Pitney Bowes Merchant,

The issue that was causing delays in sending the order related emails to the international customers has been resolved.

All Borderfree services are online and fully operational.

We apologize for any inconvenience and thank you for your continued partnership with Pitney Bowes.

Regards,
The Borderfree Production Support Team
Posted Apr 06, 2021 - 07:53 EDT
Investigating
Dear Pitney Bowes Merchant,,

We’ve been experiencing an issue that is causing delays in sending all the order related emails to the international customers.

Our team is actively investigating the issue. We will send an update as soon as possible.

If you have any questions, please contact support@borderfree.com.

Regards,
The Borderfree Production Support Team
Posted Apr 06, 2021 - 07:40 EDT