beta
Expedited Delivery Services - USPS Tracking Services Issue - Initial Notification
Incident Report for PB Products
Resolved
This incident has been resolved.
Posted Nov 15, 2023 - 00:13 EST
Update
As per the latest update from USPS, they continue to work on the issue.
Posted Nov 14, 2023 - 16:39 EST
Investigating
USPS is currently experiencing technical issues with their Tracking Services. The issue began at approximately 7:45 AM ET today.

Processing of inbound Shipping Services manifest, Shipping Partner event files, and scan events sent to PTR continue to be received but are experiencing a delay in processing. USPS Tracking® is currently available but data displayed may be stale. Customer extracts are delayed.

Once we have more updates from USPS, we will send you an update as quickly as possible.
Posted Nov 14, 2023 - 11:58 EST
This incident affected: Consumer Connect (Tracking), Returns API & Technology (Tracking), Delivery API & Technology (Tracking), and Ecommerce APIs (Formerly Shipping API) (Tracking).