beta
Delivery API & Technology - Incident - Initial Notification
Incident Report for PB Products
Resolved
This incident has been resolved.
Posted May 17, 2024 - 15:45 EDT
Investigating
We are currently experiencing technical issues with our Delivery PRODUCTION environment that may prevent you from Creating UPS shipments.
Issue is from UPS carrier and we are working with them.
Posted May 17, 2024 - 15:12 EDT
This incident affected: Delivery API & Technology (Delivery Integration (API & Files)).