beta
Borderfree Unscheduled Downtime
Incident Report for PB Products
Resolved
Dear Pitney Bowes Merchant,

The issue that was preventing you from creating a return (also referred to as an RMA, or return merchandise authorization) for orders in Consulate has been resolved.

All Borderfree services are online and fully operational.

We apologize for any inconvenience and thank you for your continued partnership with Pitney Bowes.

Regards,
The Borderfree Production Support Team
Posted 27 days ago. Sep 23, 2019 - 15:23 EDT
Investigating
Dear Pitney Bowes Merchant,

One of our third party providers is experiencing issues that may prevent you from creating a return (also referred to as an RMA, or return merchandise authorization) for orders in Consulate.

We are in communications with the third party providers team and we will send an update as soon as possible.

If you have any questions, please contact support@borderfree.com.

Regards,
The Borderfree Production Support Team
Posted 27 days ago. Sep 23, 2019 - 14:42 EDT
This incident affected: Cross-Border Retail (Consulate).