beta
Client Connect Portal Incident - Initial Notification
Incident Report for PB Products
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 04:04 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 19, 2024 - 01:56 EDT
Investigating
We are currently experiencing technical issues with our PB Client Connect that may prevent you from accessing the Client Connect Portal.

Our Emergency Response Team is investigating to determine the full scope of the outage and will be working to restore the operations. We will send you an update as quickly as possible.
Posted Sep 18, 2024 - 13:35 EDT
This incident affected: Client Connect (client.pitneybowes.com).