beta
Borderfree Unscheduled Downtime
Incident Report for PB Products
Resolved
Dear Pitney Bowes Merchant,

The issue that was preventing you from accessing the Merchant Reporting Tool has been resolved.

All Borderfree services are online and fully operational.

We apologize for any inconvenience and thank you for your continued partnership with Pitney Bowes.

Regards,
The Borderfree Production Support Team
Posted Sep 16, 2020 - 13:17 EDT
Investigating
Dear Pitney Bowes Merchant,

We’ve been experiencing an issue with the Merchant Reporting Tool in Consulate that may prevent you from accessing merchant reports.

Our team is actively investigating the issue. We will send an update as soon as possible.

If you have any questions, please contact support@borderfree.com.

Regards,
The Borderfree Production Support Team
Posted Sep 16, 2020 - 12:36 EDT