beta
SANDBOX - Pitney Bowes Merchant Portal Incident
Incident Report for PB Products
Resolved
New merchant signup through the Merchant Portal functionality is working now.

If you experience any issues, please contact the PB Shipping API Support Team at ClientSupportTechServices@pb.com.
Posted Jun 11, 2024 - 22:46 EDT
Investigating
We are currently experiencing technical issues with new merchant signup through the Merchant Portal in SANDBOX environment (TEST) .

This issue is specific to new merchant signup, the rest of the merchant portal functionalities are not affected.

Our Emergency Response Team is investigating to determine the full scope of the outage and will be working to restore the operations. We will send you an update as quickly as possible.
Posted Jun 11, 2024 - 21:48 EDT
This incident affected: Ecommerce APIs (Formerly Shipping API) – Sandbox (Merchant Portal).