beta
Cross-Border Retail - Catalog Processing Delays
Incident Report for PB Products
Resolved
Dear Pitney Bowes Merchant,

Catalog processing has returned to its normal processing times. All the backlog has been cleared.

All Borderfree services are online and fully operational.

We apologize for any inconvenience and thank you for your continued partnership with Pitney Bowes.

Regards,
The Borderfree Production Support Team
Posted Feb 14, 2021 - 08:02 EST
Monitoring
Dear Pitney Bowes Merchant,

The catalogs in the queue are being processed. We will update as soon as all the backlog is cleared.

If you have any questions, please contact support@borderfree.com.

Regards,
The Borderfree Production Support Team
Posted Feb 13, 2021 - 20:22 EST
Investigating
Dear Pitney Bowes Merchant,,

We’ve been experiencing delays with catalog processing. Our team is actively investigating the issue. We will send an update as soon as possible.

If you have any questions, please contact support@borderfree.com.

Regards,
The Borderfree Production Support Team
Posted Feb 13, 2021 - 14:45 EST