beta
Fulfillment - Incident (Client Portal) – Initial Notification
Incident Report for PB Products
Resolved
At this time we are seeing full functionality restored.
Posted Jul 23, 2020 - 15:27 EDT
Identified
The Emergency Response team has determined that the issue was caused by a Google update to the Chrome browser. Please use Internet Explorer or Firefox until this is resolved.
Posted Jul 21, 2020 - 21:01 EDT
Investigating
We are currently experiencing technical issues affecting the Fulfillment Client Portal for clients attempting to print a Return Label using the Chrome browser. Other browsers are not impacted.

Our Emergency Response Team is investigating to determine the full scope and will be working to restore the Fulfillment Client Portal to full capacity. We will send you an update as quickly as possible.
Posted Jul 21, 2020 - 20:14 EDT
This incident affected: Fulfillment API & Technology (Fulfillment Client Portal).