beta
Delivery API & Technology - Incident - Initial Notification
Incident Report for PB Products
Resolved
We experienced a technical issue with our USPS tracking services that might have prevented you from using tracking events for USPS. We began seeing recovery at around 9:00 AM ET and we are closely monitoring. At this time we see full functionality in the Delivery System.
Posted Feb 15, 2021 - 10:14 EST
Investigating
We are currently experiencing technical issues with our USPS tracking services that may prevent you from using tracking events from USPS.

Our Emergency Response Team is investigating to determine the full scope of the outage and will be working to restore the operation of Deliveries. We will send you an update as quickly as possible.
Posted Feb 15, 2021 - 02:32 EST
This incident affected: Delivery API & Technology (Tracking).